+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16

Thread: Trouble loading first round

Click here to increase the font size Click here to reduce the font size
  1. #11
    Senior Member musketjon's Avatar
    Join Date
    Mar 2009
    Last On
    08-12-2020 @ 03:40 AM
    Posts
    105
    Local Date
    09-22-2020
    Local Time
    12:47 AM
    One can not get M1icon thumb if loading a FULL clip of 8 rounds. It can't happen.
    Jon

  2. Thank You to musketjon For This Useful Post:


  3. # ADS
    Friends and Sponsors
    Join Date
    October 2006
    Posts
    All Threads
     

  4. #12
    Really Senior Member Orlando's Avatar
    Join Date
    Mar 2009
    Last On
    09-20-2020 @ 04:11 PM
    Posts
    317
    Local Date
    09-22-2020
    Local Time
    12:47 AM
    The only garand I have ever seen that didnt need the op rod assisted to close on the first rd was a rifle that had very worn parts. Assisting op rod to close on first rd is normal, rifle is operating as it should
    As Jon stated it is impossible to get garand thumb when loading the rifle. Garandicon thumb happens when putting your digits where they do not belong with a empty rifle

  5. Avoid Ads - Become a Contributing Member - Click HERE
  6. #13
    Contributing Member ssgross's Avatar
    Join Date
    Jan 2020
    Last On
    Yesterday @ 11:53 AM
    Location
    Virginia
    Posts
    67
    Local Date
    09-22-2020
    Local Time
    12:47 AM
    Here I thought the extra friction on the top round was solely to do with how tight the enbloc clip was. What other parts, other than maybe the upward pressure of the follower, are to blame?
    My brand newly manufactured clips all stick - once I "click" it in and remove my thumb, the top round won't go but <1/4inch forward, if at all. All of my very old stock clips the top round sticks at halfway, or zooms all the way to the chamber. Some of the new ones required more of a severe whack on the op-rod, or several whacks, to get the first round chambered. After about 10 minutes of stretching by hand to loosen it up, the top round will move 1/4inch or so forward, and a gentle love tap sends it all the way.
    Also, my new clips don't pop out of the magazine. They go "ping" but fall right back in. The old ones fly all over the place with that beautiful ringing sound, even when pulling the op-rod by hand. How to improve the clip ejection?

  7. #14
    Advisory Panel browningautorifle's Avatar
    Join Date
    Jul 2008
    Last On
    Yesterday @ 11:01 PM
    Location
    Victoria BC
    Posts
    24,092
    Local Date
    09-21-2020
    Local Time
    09:47 PM
    Try cleaning some of the parkerizing off the clips with scotchbrite or emery or some such, that may free them up.
    Regards, Jim

  8. Thank You to browningautorifle For This Useful Post:


  9. #15
    Contributing Member ssgross's Avatar
    Join Date
    Jan 2020
    Last On
    Yesterday @ 11:53 AM
    Location
    Virginia
    Posts
    67
    Local Date
    09-22-2020
    Local Time
    12:47 AM
    Quote Originally Posted by browningautorifleicon View Post
    Try cleaning some of the parkerizing off the clips with scotchbrite or emery or some such, that may free them up.
    THANKS! I put a brand new clip in the tumbler with walnut media for about half an hour. I then cleaned it with wd-40, wiped off the excess, and now it sings out of the magazine when pulling the oprod, where before it would pop up but not clear. Noticeable difference too in the first round. After taking my thumb off, the bolt moves the round forward about halfway out before sticking. Before tumbling it only moved 1/4 of the way.

  10. The Following 3 Members Say Thank You to ssgross For This Useful Post:


  11. #16
    Advisory Panel browningautorifle's Avatar
    Join Date
    Jul 2008
    Last On
    Yesterday @ 11:01 PM
    Location
    Victoria BC
    Posts
    24,092
    Local Date
    09-21-2020
    Local Time
    09:47 PM
    I always found wartime clips with some wear on them worked almost perfectly. This one will smooth up too.

    Regards, Jim

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Lee-Enfield No. 1, 4 and 5 rifles - Controlled Round Feed or Push Round Feed ?
    By Snowy Owl in forum The Lee Enfield Knowledge Library Collectors Forum
    Replies: 23
    Last Post: 02-09-2016, 11:30 PM
  2. Loading a single round?
    By Calflash in forum The Lee Enfield Knowledge Library Collectors Forum
    Replies: 13
    Last Post: 02-20-2015, 07:46 PM
  3. Replies: 3
    Last Post: 05-22-2013, 09:50 PM
  4. Trouble with my K98
    By Thumper in forum Mauser Rifles
    Replies: 6
    Last Post: 10-01-2011, 09:55 AM
  5. M91/30 trouble loading magazine
    By blackcat_attilio in forum Soviet Bloc Rifles
    Replies: 10
    Last Post: 03-16-2011, 01:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts